class MissingRequiredPackageException extends DependencyException (View source)

Package dependency failure: a package can't be installed since it requires another package that's not installed.

Properties

protected Package $notInstallablePackage The package that can't be installed.
protected string $missingPackageHandle The handle of the package that's not installed.
protected string|string[]|bool $requirements The version requirements of the not installed package.

Methods

__toString()

{@inheritdoc}

jsonSerialize()

{@inheritdoc}

__construct(Package $notInstallablePackage, string $missingPackageHandle, string|string[]|bool $requirements)

Initialize the instance.

getNotInstallablePackage()

Get the package that can't be installed.

string
getMissingPackageHandle()

Get the handle of the package that's not installed.

getRequirements()

Get the version requirements of the not installed package.

Details

__toString()

{@inheritdoc}

See also

\LogicException::__toString()

jsonSerialize()

{@inheritdoc}

See also

\JsonSerializable::jsonSerialize()

__construct(Package $notInstallablePackage, string $missingPackageHandle, string|string[]|bool $requirements)

Initialize the instance.

Parameters

Package $notInstallablePackage the package that can't be installed
string $missingPackageHandle the handle of the package that's not installed
string|string[]|bool $requirements the version requirements of the package

Package getNotInstallablePackage()

Get the package that can't be installed.

Return Value

Package

string getMissingPackageHandle()

Get the handle of the package that's not installed.

Return Value

string

getRequirements()

Get the version requirements of the not installed package.