class RequiredPackageException extends DependencyException (View source)

Package dependency failure: an installed package can't be uninstalled since it's required by another package.

Properties

protected Package $uninstallablePackage The package that can't be uninstalled.
protected Package $blockingPackage The package that requires the package that can't be uninstalled.

Methods

__toString()

{@inheritdoc}

jsonSerialize()

{@inheritdoc}

__construct(Package $uninstallablePackage, Package $blockingPackage)

Initialize the instance.

getUninstallablePackage()

Get the package that can't be uninstalled.

getBlockingPackage()

Get the package that requires the package that can't be uninstalled.

Details

__toString()

{@inheritdoc}

See also

\LogicException::__toString()

jsonSerialize()

{@inheritdoc}

See also

\JsonSerializable::jsonSerialize()

__construct(Package $uninstallablePackage, Package $blockingPackage)

Initialize the instance.

Parameters

Package $uninstallablePackage the package that can't be uninstalled
Package $blockingPackage the package that requires the package that can't be uninstalled

Package getUninstallablePackage()

Get the package that can't be uninstalled.

Return Value

Package

Package getBlockingPackage()

Get the package that requires the package that can't be uninstalled.

Return Value

Package