class VersionMismatchException extends DependencyException (View source)

Package dependency failure: a package requires specific versions of another package.

Properties

protected Package $blockingPackage The package that causes the dependency problem.
protected Package $package The package that fails the requirement.
protected string|string[] $requiredVersion The required package version.

Methods

__toString()

{@inheritdoc}

jsonSerialize()

{@inheritdoc}

__construct(Package $blockingPackage, Package $package, string|string[] $requiredVersion)

Initialize the instance.

getBlockingPackage()

Get the package that causes the dependency problem.

getPackage()

Get the package that fails the requirement.

string|string[]
getRequiredVersion()

Get the required package version.

Details

__toString()

{@inheritdoc}

See also

\LogicException::__toString()

jsonSerialize()

{@inheritdoc}

See also

\JsonSerializable::jsonSerialize()

__construct(Package $blockingPackage, Package $package, string|string[] $requiredVersion)

Initialize the instance.

Parameters

Package $blockingPackage the package that causes the dependency problem
Package $package the package that fails the requirement
string|string[] $requiredVersion the required package version

Package getBlockingPackage()

Get the package that causes the dependency problem.

Return Value

Package

Package getPackage()

Get the package that fails the requirement.

Return Value

Package

string|string[] getRequiredVersion()

Get the required package version.

Return Value

string|string[]